A. System Requirements

Last modified by teamwire001 on 2024/01/02 07:34

Mobile

Supported Operating Systems:

  • iOS 14.0 or newer
  • iPadOS 14.0 or newer
  • Android 8.0 or newer

Desktop

Minimum Hardware Specs:

  • Intel Pentium 4 processor (supporting SSE2 instruction set or higher)

Supported Operating Systems:

  • Microsoft Windows 8 / 8.1 / 10 / 11
  • macOS Sierra 10.12 or newer
  • OS X Yosemite 10.10 / El Capitan 10.11
  • 64-bit Ubuntu 14.04 or newer
  • Fedora 24 or newer

Web Client

Supported Browsers:

  • Mozilla Firefox 44 or newer
  • Google Chrome 49 or newer
  • Microsoft Edge 17 or newer
  • Safari 11.1 or newer

Server

Teamwire will provide a VM image with one of the supported operating systems:

  • Debian 10 "Buster" (amd64) - End of support: March 31, 2024
  • Debian 11 "Bullseye" (amd64)
  • Debian 12 "Bookworm" (amd64)

Supported Hypervisors:

  • VMware (OVA)
  • KVM (QCOW2)

Supported External DBMS:

  • MariaDB
    • 10.3 (Debian 10) - End of support: March 31, 2024
    • 10.5 (Debian 11)
    • 10.11 (Debian 12)
  • Oracle RDBMS
    • 18.4

Further information about scaling your Teamwire Server environment can be found here: Server Deployment and Server Example Setups.

Teamwire API

Our apps and server appliances always support the latest and two preceding Teamwire API versions.

This means we currently support

  • API 18
  • API 17
  • API 16

More information about the compatibility between Teamwire apps and backend are available here: Teamwire API List

 

Tags:
Created by teamwire001 on 2021/06/10 09:56
   

Last edited

2024/01/02

Teamwire GmbH